#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)'(\\x[0-9a-fA-F]{2}|\\u[0-9a-fA-F]{4})*'"
Local $sString = "'\x0F'" & @CRLF & _
"'\u0fff'" & @CRLF & _
"'23'" & @CRLF & _
"'teset'" & @CRLF & _
"'wer.fee'" & @CRLF & _
"" & @CRLF & _
"'\x0FF'" & @CRLF & _
"'\u0fff\x'" & @CRLF & _
"'\u0fff\'\'" & @CRLF & _
"'\u0fff"'" & @CRLF & _
"'\u0fff\b'" & @CRLF & _
"'\u0fff\f'" & @CRLF & _
"'\u0fff\n'" & @CRLF & _
"'\u0fff\r'" & @CRLF & _
"'\u0fff\t'" & @CRLF & _
"'\u0fff\v'" & @CRLF & _
"'\u0fff\n'" & @CRLF & _
"'\u0fff\\'" & @CRLF & _
"'\u0fff\r'" & @CRLF & _
"'\u0fff\\u2028'" & @CRLF & _
"'\u0fff\\u2029'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")