# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"'(\\x[0-9a-fA-F]{2}|\\u[0-9a-fA-F]{4})*'"
test_str = ("'\\x0F'\n"
"'\\u0fff'\n"
"'23'\n"
"'teset'\n"
"'wer.fee'\n\n"
"'\\x0FF'\n"
"'\\u0fff\\x'\n"
"'\\u0fff\\'\\'\n"
"'\\u0fff\"'\n"
"'\\u0fff\\b'\n"
"'\\u0fff\\f'\n"
"'\\u0fff\\n'\n"
"'\\u0fff\\r'\n"
"'\\u0fff\\t'\n"
"'\\u0fff\\v'\n"
"'\\u0fff\\n'\n"
"'\\u0fff\\\\'\n"
"'\\u0fff\\r'\n"
"'\\u0fff\\\\u2028'\n"
"'\\u0fff\\\\u2029'")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.