import Foundation
let pattern = #"Host\s+host2\s.*?IdentityFile\s+(?<identity>\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
Host host1
HostName 192.168.1.2
User user
Port 22
IdentityFile ~/.ssh/host1
Host host2
HostName 192.168.1.3
User user
Port 22
IdentityFile ~/.ssh/host2
Host host3
HostName 192.168.1.4
User user
Port 22
IdentityFile ~/.ssh/host3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}