using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Host\s+host2\s.*?IdentityFile\s+(?<identity>\S+)";
string input = @"Host host1
HostName 192.168.1.2
User user
Port 22
IdentityFile ~/.ssh/host1
Host host2
HostName 192.168.1.3
User user
Port 22
IdentityFile ~/.ssh/host2
Host host3
HostName 192.168.1.4
User user
Port 22
IdentityFile ~/.ssh/host3";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}