// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)Host\s+host2\s.*?IdentityFile\s+(?<identity>\S+)").unwrap();
let string = "Host host1
HostName 192.168.1.2
User user
Port 22
IdentityFile ~/.ssh/host1
Host host2
HostName 192.168.1.3
User user
Port 22
IdentityFile ~/.ssh/host2
Host host3
HostName 192.168.1.4
User user
Port 22
IdentityFile ~/.ssh/host3";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}