package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)Host\s+host2\s.*?IdentityFile\s+(?<identity>\S+)`)
var str = `Host host1
HostName 192.168.1.2
User user
Port 22
IdentityFile ~/.ssh/host1
Host host2
HostName 192.168.1.3
User user
Port 22
IdentityFile ~/.ssh/host2
Host host3
HostName 192.168.1.4
User user
Port 22
IdentityFile ~/.ssh/host3`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}