import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Host\\s+host2\\s.*?IdentityFile\\s+(?<identity>\\S+)";
final String string = "Host host1\n"
+ " HostName 192.168.1.2\n"
+ " User user\n"
+ " Port 22\n"
+ " IdentityFile ~/.ssh/host1\n\n"
+ "Host host2\n"
+ " HostName 192.168.1.3\n"
+ " User user\n"
+ " Port 22\n"
+ " IdentityFile ~/.ssh/host2\n\n"
+ "Host host3\n"
+ " HostName 192.168.1.4\n"
+ " User user\n"
+ " Port 22\n"
+ " IdentityFile ~/.ssh/host3";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}