const regex = /Host\s+host2\s.*?IdentityFile\s+(?<identity>\S+)/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Host\\s+host2\\s.*?IdentityFile\\s+(?<identity>\\S+)', 's')
const str = `Host host1
HostName 192.168.1.2
User user
Port 22
IdentityFile ~/.ssh/host1
Host host2
HostName 192.168.1.3
User user
Port 22
IdentityFile ~/.ssh/host2
Host host3
HostName 192.168.1.4
User user
Port 22
IdentityFile ~/.ssh/host3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}