$re = '/Host\s+host2\s.*?IdentityFile\s+(?<identity>\S+)/s';
$str = 'Host host1
HostName 192.168.1.2
User user
Port 22
IdentityFile ~/.ssh/host1
Host host2
HostName 192.168.1.3
User user
Port 22
IdentityFile ~/.ssh/host2
Host host3
HostName 192.168.1.4
User user
Port 22
IdentityFile ~/.ssh/host3';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);