re = /^\s*[0-9]* *([a-zA-Z]+[0-9]*)+( *\+ *[0-9]*([a-zA-Z]{1,2}[0-9]*))*\s*$/m
str = 'A + B
2H2 + O2
2H2O
C + O2
2H2O
2H2O
2H2O '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result