# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s*[0-9]* *([a-zA-Z]+[0-9]*)+( *\+ *[0-9]*([a-zA-Z]{1,2}[0-9]*))*\s*$//gm;t' <<< "A + B
2H2 + O2
2H2O
C + O2
2H2O
2H2O
2H2O "