const regex = /^\s*[0-9]* *([a-zA-Z]+[0-9]*)+( *\+ *[0-9]*([a-zA-Z]{1,2}[0-9]*))*\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*[0-9]* *([a-zA-Z]+[0-9]*)+( *\\+ *[0-9]*([a-zA-Z]{1,2}[0-9]*))*\\s*$', 'gm')
const str = `A + B
2H2 + O2
2H2O
C + O2
2H2O
2H2O
2H2O `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);