use strict;
my $str = 'A + B
2H2 + O2
2H2O
C + O2
2H2O
2H2O
2H2O ';
my $regex = qr/^\s*[0-9]* *([a-zA-Z]+[0-9]*)+( *\+ *[0-9]*([a-zA-Z]{1,2}[0-9]*))*\s*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";