#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\s*[0-9]* *([a-zA-Z]+[0-9]*)+( *\+ *[0-9]*([a-zA-Z]{1,2}[0-9]*))*\s*$"
Local $sString = "A + B" & @CRLF & _
"2H2 + O2" & @CRLF & _
"2H2O" & @CRLF & _
"C + O2" & @CRLF & _
"2H2O " & @CRLF & _
" 2H2O" & @CRLF & _
" 2H2O "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)