package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*[0-9]* *([a-zA-Z]+[0-9]*)+( *\+ *[0-9]*([a-zA-Z]{1,2}[0-9]*))*\s*$`)
var str = `A + B
2H2 + O2
2H2O
C + O2
2H2O
2H2O
2H2O `
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}