re = /\b(?<!-)(?:\d{1,2}|100)\b/mi
str = 'Sam has 200 apples. He gives Todd 20 and Mary 125.
The weather is -5 C today, but will be +5 C tomorrow.'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result