# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?<!-)(?:\d{1,2}|100)\b"
test_str = ("Sam has 200 apples. He gives Todd 20 and Mary 125.\n"
"The weather is -5 C today, but will be +5 C tomorrow.")
subst = "-"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.