const regex = /\b(?<!-)(?:\d{1,2}|100)\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?<!-)(?:\\d{1,2}|100)\\b', 'gmi')
const str = `Sam has 200 apples. He gives Todd 20 and Mary 125.
The weather is -5 C today, but will be +5 C tomorrow.`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);