#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)\b(?<!-)(?:\d{1,2}|100)\b"
Local $sString = "Sam has 200 apples. He gives Todd 20 and Mary 125." & @CRLF & _
"The weather is -5 C today, but will be +5 C tomorrow."
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)