use strict;
my $str = 'Sam has 200 apples. He gives Todd 20 and Mary 125.
The weather is -5 C today, but will be +5 C tomorrow.';
my $regex = qr/\b(?<!-)(?:\d{1,2}|100)\b/mip;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";