import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<!-)(?:\\d{1,2}|100)\\b";
final String string = "Sam has 200 apples. He gives Todd 20 and Mary 125.\n"
+ "The weather is -5 C today, but will be +5 C tomorrow.";
final String subst = "-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}