using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?<!-)(?:\d{1,2}|100)\b";
string substitution = @"-";
string input = @"Sam has 200 apples. He gives Todd 20 and Mary 125.
The weather is -5 C today, but will be +5 C tomorrow.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}