// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\/]*(\/.*?):(.*)$").unwrap();
let string = "dregistry.service.local:4000/msi/paas-cluster-manager:2.2.141401
dregistry.service.local:4000/paas-cluster-manager:2.2.141401";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}