const regex = /^[^\/]*(\/.*?):(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\\/]*(\\\/.*?):(.*)$', 'gm')
const str = `dregistry.service.local:4000/msi/paas-cluster-manager:2.2.141401
dregistry.service.local:4000/paas-cluster-manager:2.2.141401`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);