using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\/]*(\/.*?):(.*)$";
string substitution = @"\1";
string input = @"dregistry.service.local:4000/msi/paas-cluster-manager:2.2.141401
dregistry.service.local:4000/paas-cluster-manager:2.2.141401";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}