use strict;
my $str = 'dregistry.service.local:4000/msi/paas-cluster-manager:2.2.141401
dregistry.service.local:4000/paas-cluster-manager:2.2.141401';
my $regex = qr/^[^\/]*(\/.*?):(.*)$/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";