re = /^[^\/]*(\/.*?):(.*)$/m
str = 'dregistry.service.local:4000/msi/paas-cluster-manager:2.2.141401
dregistry.service.local:4000/paas-cluster-manager:2.2.141401'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result