import Foundation
let pattern = #"\[(.*?)\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Attacks for [1d20+3] damage.
[genderPronoun] is [1d18] years old.
[genderPronoun] is carrying a quiver with [1d8] arrows
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"1231"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)