using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(.*?)\]";
string substitution = @"1231";
string input = @"Attacks for [1d20+3] damage.
[genderPronoun] is [1d18] years old.
[genderPronoun] is carrying a quiver with [1d8] arrows
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}