package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(.*?)\]`)
var str = `Attacks for [1d20+3] damage.
[genderPronoun] is [1d18] years old.
[genderPronoun] is carrying a quiver with [1d8] arrows
`
var substitution = "1231"
fmt.Println(re.ReplaceAllString(str, substitution))
}