$re = '/\[(.*?)\]/';
$str = 'Attacks for [1d20+3] damage.
[genderPronoun] is [1d18] years old.
[genderPronoun] is carrying a quiver with [1d8] arrows
';
$subst = "1231";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;