# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[(.*?)\]/1231/g;t' <<< "Attacks for [1d20+3] damage.
[genderPronoun] is [1d18] years old.
[genderPronoun] is carrying a quiver with [1d8] arrows
"