const regex = /\[(.*?)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(.*?)\\]', 'g')
const str = `Attacks for [1d20+3] damage.
[genderPronoun] is [1d18] years old.
[genderPronoun] is carrying a quiver with [1d8] arrows
`;
const subst = `1231`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);