// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[(.*?)\]").unwrap();
let string = "Attacks for [1d20+3] damage.
[genderPronoun] is [1d18] years old.
[genderPronoun] is carrying a quiver with [1d8] arrows
";
let substitution = "1231";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}