# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((https?:\/\/)?[^\s.]+\.[\w][^\s]+)"
test_str = ("example.com\n"
"example.com/\n"
"ExaMp1e.com\n"
"example.com/example\n"
"example.com/example/\n"
"example.example.example.example.com/example\n"
"http://www.example.com\n"
"http://www.example.com/\n"
"http://www.example.com/example\n"
"http://www.example.com/example/\n"
"www.example.com\n"
"www.example.com/example\n"
"email@example.com\n\n"
".\n"
"...\n"
"example...\n"
".example\n"
".example/\n"
"/example\n"
"...example\n"
"example. Example\n"
"1.1v")
subst = "<a href=\"$1\" target=_blank\">$1</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.