import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((https?:\\/\\/)?[^\\s.]+\\.[\\w][^\\s]+)";
final String string = "example.com\n"
+ "example.com/\n"
+ "ExaMp1e.com\n"
+ "example.com/example\n"
+ "example.com/example/\n"
+ "example.example.example.example.com/example\n"
+ "http://www.example.com\n"
+ "http://www.example.com/\n"
+ "http://www.example.com/example\n"
+ "http://www.example.com/example/\n"
+ "www.example.com\n"
+ "www.example.com/example\n"
+ "email@example.com\n\n"
+ ".\n"
+ "...\n"
+ "example...\n"
+ ".example\n"
+ ".example/\n"
+ "/example\n"
+ "...example\n"
+ "example. Example\n"
+ "1.1v";
final String subst = "<a href=\"$1\" target=_blank\">$1</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}