use strict;
my $str = 'example.com
example.com/
ExaMp1e.com
example.com/example
example.com/example/
example.example.example.example.com/example
http://www.example.com
http://www.example.com/
http://www.example.com/example
http://www.example.com/example/
www.example.com
www.example.com/example
email@example.com
.
...
example...
.example
.example/
/example
...example
example. Example
1.1v';
my $regex = qr/((https?:\/\/)?[^\s.]+\.[\w][^\s]+)/mp;
my $subst = '<a href="$1" target=_blank">$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";