using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((https?:\/\/)?[^\s.]+\.[\w][^\s]+)";
string substitution = @"<a href=""$1"" target=_blank"">$1</a>";
string input = @"example.com
example.com/
ExaMp1e.com
example.com/example
example.com/example/
example.example.example.example.com/example
http://www.example.com
http://www.example.com/
http://www.example.com/example
http://www.example.com/example/
www.example.com
www.example.com/example
email@example.com
.
...
example...
.example
.example/
/example
...example
example. Example
1.1v";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}