package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((https?:\/\/)?[^\s.]+\.[\w][^\s]+)`)
var str = `example.com
example.com/
ExaMp1e.com
example.com/example
example.com/example/
example.example.example.example.com/example
http://www.example.com
http://www.example.com/
http://www.example.com/example
http://www.example.com/example/
www.example.com
www.example.com/example
email@example.com
.
...
example...
.example
.example/
/example
...example
example. Example
1.1v`
var substitution = "<a href="$1" target=_blank">$1</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}