$re = '/((https?:\/\/)?[^\s.]+\.[\w][^\s]+)/m';
$str = 'example.com
example.com/
ExaMp1e.com
example.com/example
example.com/example/
example.example.example.example.com/example
http://www.example.com
http://www.example.com/
http://www.example.com/example
http://www.example.com/example/
www.example.com
www.example.com/example
email@example.com
.
...
example...
.example
.example/
/example
...example
example. Example
1.1v';
$subst = "<a href=\"$1\" target=_blank\">$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;