const regex = /((https?:\/\/)?[^\s.]+\.[\w][^\s]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((https?:\\\/\\\/)?[^\\s.]+\\.[\\w][^\\s]+)', 'gm')
const str = `example.com
example.com/
ExaMp1e.com
example.com/example
example.com/example/
example.example.example.example.com/example
http://www.example.com
http://www.example.com/
http://www.example.com/example
http://www.example.com/example/
www.example.com
www.example.com/example
email@example.com
.
...
example...
.example
.example/
/example
...example
example. Example
1.1v`;
const subst = `<a href="$1" target=_blank">$1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);