// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:eu|us|jp)01\.agent\.edr\.eset\.systems$").unwrap();
let string = "eu01.agent.edr.eset.systems
us01.agent.edr.eset.systems
jp01.agent.edr.eset.systems";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}