using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:eu|us|jp)01\.agent\.edr\.eset\.systems$";
string input = @"eu01.agent.edr.eset.systems
us01.agent.edr.eset.systems
jp01.agent.edr.eset.systems";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}