import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:eu|us|jp)01\\.agent\\.edr\\.eset\\.systems$";
final String string = "eu01.agent.edr.eset.systems\n"
+ "us01.agent.edr.eset.systems\n"
+ "jp01.agent.edr.eset.systems";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}