$re = '/^(?:eu|us|jp)01\.agent\.edr\.eset\.systems$/mi';
$str = 'eu01.agent.edr.eset.systems
us01.agent.edr.eset.systems
jp01.agent.edr.eset.systems';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);