package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:eu|us|jp)01\.agent\.edr\.eset\.systems$`)
var str = `eu01.agent.edr.eset.systems
us01.agent.edr.eset.systems
jp01.agent.edr.eset.systems`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}