re = /^(?:eu|us|jp)01\.agent\.edr\.eset\.systems$/mi
str = 'eu01.agent.edr.eset.systems
us01.agent.edr.eset.systems
jp01.agent.edr.eset.systems'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end