const regex = /^(?:eu|us|jp)01\.agent\.edr\.eset\.systems$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:eu|us|jp)01\\.agent\\.edr\\.eset\\.systems$', 'gmi')
const str = `eu01.agent.edr.eset.systems
us01.agent.edr.eset.systems
jp01.agent.edr.eset.systems`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}