// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)<(?:(?<tag>[^\/<>\s]+)(?:\s+(?<attr>[^=>]*)="(?<value>[^"]*)")*|\/?(?<close>(?&tag))\/?)>"#).unwrap();
let string = "<div id=\"lorem\" class=\"ipsum\">Hello World</div><div class=\"lorem\">Ciao mondo<a href=\"#\">clicca qui</a></div><div id=\"lorem\" class=\"ipsum\">Hello World</div><div class=\"lorem\">Ciao mondo<a href=\"#\">clicca qui</a></div>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}