# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(?:(?<tag>[^\\/<>\s]+)(?:\s+(?<attr>[^=>]*)="(?<value>[^"]*)")*|\\/?(?<close>(?&tag))\\/?)>//gi;t' <<< "<div id=\"lorem\" class=\"ipsum\">Hello World</div><div class=\"lorem\">Ciao mondo<a href=\"#\">clicca qui</a></div><div id=\"lorem\" class=\"ipsum\">Hello World</div><div class=\"lorem\">Ciao mondo<a href=\"#\">clicca qui</a></div>"